Tips and Tricks from Forum Users #17

“The pain passes but the beauty remains.”

– Auguste Renoir

 

I subscribe.

 

For your viewing pleasure, here’s another painstakingly crafted set of your own Solid Edge tips and tricks illustrated with images and animations.

 

Here’s a quick list of the previous compilations:

T&T #01T&T #02T&T #03T&T #04T&T #05

T&T #06T&T #07T&T #08T&T #09,   T&T #10

T&T #11T&T #12T&T #13,   T&T #14T&T #15

T&T #16

 

I have collated hidden tips and tricks from ‘accepted solutions’ on the Solid Edge user forum.

Also due credit is given to respective contributors.

1. I am doing manually exploded views of upper level assemblies and cannot select an entire subassembly within the upper level assembly. I have to go through and select each individual part in the subassembly to explode it. Am I missing something or is there a way around this ?

  

The Tip: Within the ERA environment the “Bind” command will bind sub assemblies to act as a single unit.

  

Select the sub-assembly in the pathfinder and click the button for Bind on Home tab, Modify group on the ribbon.

 TnT1707.png

The pathfinder icon for the sub-assembly updates to reflect this.

TnT1708.png 

 

Now you can select any component of the sub-assembly to move it as a coherent unit.

 

Contributor: @Johnson_BigMatt

 

2. Why can I not select any of the reference planes sometimes when trying to constrain parts? Everything is activated, updated and no sick relations. I have closed the assembly and reopened but that didn’t help.

 

The Tip: Make sure you don’t have perspective on. To turn off perspective, keep Ctrl+Shift pressed and scroll the mouse wheel down or towards you or on the View toolbar click the Perspective button.

 

 TnT1701.png

Contributors: @bshand and @SeanCresswell

 

Hot Tip by @GregLuckett: This is fixed in ST10, so you can select reference planes with perspective applied to the view.

 

3. How do I get assembly weight in a Draft callout and have it updated automatically?

 

The Tip: A callout property with  %{Mass|R1}  will do the trick.

 

 TnT1702.png

Back in the assembly, check ON the box for ‘Update on file save. This will automatically update the mass properties when the assembly is saved and the value in the callout in the Draft when opened will always be correct.

TnT1703.png

Set your template to update on file save, and just hit save to update the mass.

Contributors: @Jan_Bos@BoatTech and yours sincerely – myself

4. How to tilt a dimension something like in this picture.

TnT1704.png 

The Tip:

  

  1. Select the dimension.
  2. Right mouse click on it and select Properties.
  3. In the Dimension Properties dialog select the Lines and Coordinate tab.
  4. In the Projection Line section change the Angle field to whatever you want (15°).
  5. Click OK.

TnT1705.png

Contributors: @hawcad and @KennyG

 

5. How can I avoid overlapping of balloons when they are auto-created ?

 

The Tip: This can be done by adjusting the minimum spacing value.

 

 BalloonSpacing.gif

Contributor:  @hawcad

6. When I create Automatic Coordinate Dimensions with the Jog option checked ON on the Command Bar, I still don’t get the jogs ?

 

The Tip: Make sure under the active dimension style the ‘Enable automatic jogging’ option is checked ON under the Lines and Coordinate tab.

 

TnT1710.png

Contributor: @dcstaples

7. I am using the same title block for standard parts and sheet metal parts. In the title block I have the bend radius and K-factor code shown.

 

%{Bend Radius|R1}

%{Neutral Factor|R1}

 

This is fine when I have a sheet metal part. When I have a standard part these codes show ‘Error: No reference’.

 

 TnT1706.png

Can I have ‘N/A’ or ‘-‘ show in its place when a sheet metal part is not used ?

  

The Tip: Yes. Open a Draft and Solid Edge App button -> Settings -> Options -> General -> “Property text editor” -> Show my error: N/A. Apply all changes.

 TnT1712.png

Contributor: @Imics

 

8. I am trying to open a Parasolid x_t file of an assembly exported from Inventor but it won’t open. It appears to be loading for a while and then stops. It stays in the Solid Edge home page where I started. I cannot see the progress bar with the message saying ‘Converting parasolid entities…’ or anything like that.

What could be the possible cause and how to fix this ?

 

The Tip: It is important to match the Parasolid versions from the source program and import options in Solid Edge. Possibly the x_t file is not a version that you can import with your current version of Solid Edge.

 

To verify this quickly, open a Solid Edge assembly, then try saving it as Parasolid x_t. Click the Options… button while in the Save dialog and see what is the latest parasolid versions you can export. It will possibly be something like 13 or 14, maybe even lower.

 

TnT1711.png

Then export as that Parasolid version from Inventor.

 

Contributor: @beachcomber

 

Topics

Leave a Reply